mac el capitan: patcher(?) automatically closes

Post here to ask for technical support with your game client, patcher, kRO/Sakray Setup
Forum rules
****** !!! A T T E N T I O N !!! ******

Before opening a new support request or replying to an existing one, please make sure you read the General Troubleshooting Instructions.
Only if the instructions described there don't resolve - or don't apply to - your issue, please open a new thread, stating what you did so far.

Any requests that clearly don't follow these instructions may be ignored, locked, or deleted.

****** !!! A T T E N T I O N !!! ******

mac el capitan: patcher(?) automatically closes

Postby meringue » 2020-01-29 17:16 (Wednesday)

Hello~
So I'm running a macbook osx el capitan 10.11.16 idk if that's important.

I used the utility app and the Originsroapp folder is in my applications folder. When I ran the launcher I clicked allow for the updates. So now in the launcher in the bottom right window it beside OriginsRO "patch" is in red so I clicked "patch". An icon with the red headed girl appears on my dock but in the few seconds that app just closes by itself. "patch" remains red when I relaunch the launcher. I've tried deleting the Originsroruntime.bundle a few times already but the same thing happens.

I tried some of the suggestions here "https://bbs.originsro.org/viewtopic.php?f=25&t=2873" and noticed that when I hit "graphic / sound / advance options" button the red headed icon thingie appears on my dock but then disappears within a few seconds also. No windows appear.

When I use the problem detector command I get the following:
Checking for temporary WS files...
ls: /tmp/xWSx*: No such file or directory
Testing connectivity to the OriginsRO server...
(this may take a while)
Connection to game.originsro.org port 80 [tcp/http] succeeded!
Connection to game.originsro.org port 443 [tcp/https] succeeded!
Connection to game.originsro.org port 6120 [tcp/*] succeeded!
Connection to game.originsro.org port 6121 [tcp/*] succeeded!
Connection to game.originsro.org port 6122 [tcp/bex-webadmin] succeeded!
Connection to apac.originsro.org port 6120 [tcp/*] succeeded!
Connection to apac.originsro.org port 6121 [tcp/*] succeeded!
Connection to apac.originsro.org port 6122 [tcp/bex-webadmin] succeeded!
Connection to patch.originsro.org port 80 [tcp/http] succeeded!
Connection to patch.originsro.org port 443 [tcp/https] succeeded!
Connection to login.originsro.org port 80 [tcp/http] succeeded!
Connection to login.originsro.org port 443 [tcp/https] succeeded!
========================== [End here] =============================
(all lines before the above has my name on it so i figured they weren't relevant?)

And this is what it says on the .txt report file from the launcher

OriginsRO Patch Version Checker Log
Log v.4.3.3
2020-01-29 16:49:08+0000
02:c4:00:84:64:00:26:dd:8e:98:57:e6:cb:10:89:b0:80:a6:f6:48:26:ec:bd:77:4d:e1
================================================================
kRO:
data.grf presence: Yes
kRagnarokPatcher.exe presence: Yes
Last patched: 3059::3059 (0x00000bf3 / 0x07)
================================================================
OriginsRO:
OrigRO/main.orp presence: Yes
OriginsroPatcher.exe presence: Yes
Last patched: 152::89 (0x00000059 / 0x03)
================================================================
System Info: Macintosh / OS X 10.11 El Capitan (15.6.0)
Game Directory: /Applications/OriginsroApp/OriginsRO
Launcher Directory: /Applications/OriginsroApp/OriginsroLauncher.app/Contents/MacOS



I tried deleting and redownloading everything too and get the same problems. I even manually installing that i got from this thread viewtopic.php?f=25&t=1628

but still same issue.

Actually I remember I had this same issue when i tried downloading the game for my mac in 2018 or early 19 and got the same issue. But just went into bootcamp so I didn't bother with it, but I'd like to try it again on my mac.

Hope someone can help and sorry if i just did something dumb :D
User avatar
meringue
Player
Player
Poring
Poring
 
Posts: 2
Joined: 2018-10-11 01:45 (Thursday)
Gender: Not Telling

Re: mac el capitan: patcher(?) automatically closes

Postby GM Ischia » 2020-02-05 01:06 (Wednesday)

Hey,

sorry for the late response. It looks like you are actively playing your account again. Is this issue fixed? How did you solve it? (In case anyone has a similar issue)
[GM] Ischia
User avatar
GM Ischia
Player
Player
Stapo
Stapo
 
Posts: 259
Joined: 2019-08-15 02:12 (Thursday)
Gender: Female

Re: mac el capitan: patcher(?) automatically closes

Postby meringue » 2020-02-06 17:36 (Thursday)

No biggie on the reply :3

I didn't solve it actually. I just used bootcamp again. :( i'd still prefer to use my mac os though so i'd be glad if anyone has any suggestions.
User avatar
meringue
Player
Player
Poring
Poring
 
Posts: 2
Joined: 2018-10-11 01:45 (Thursday)
Gender: Not Telling


Return to Technical Support



Who is online

Users browsing this forum: No registered users and 12 guests