Mystical Amp + Storm Gust glitch (?)

This is the place where you can chat about anything related to OriginsRO and Ragnarok Online. This is NOT for technical support or requests to GMs.
Forum rules
This section is NOT meant for technical support or GM assistance requests and may be not monitored by GMs everyday. The appropriate places for that kind of requests are the Technical Support forum and the Questions and Support tracker.

Mystical Amp + Storm Gust glitch (?)

Postby stockings » 2020-09-15 23:09 (Tuesday)

A strange rumor persists: Only the first hit of Storm Gust is amplified through Mystical Amp.

I can't even count how often i've read about this in the #support and #main chats.

I couldn't confirm this - my Mystical Amp + SG work as intended (All hits are amplified). So what's up?
User avatar
stockings
Player
Player
Poring
Poring
 
Posts: 2
Joined: 2020-07-31 20:59 (Friday)
Gender: Not Telling

Re: Mystical Amp + Storm Gust glitch (?)

Postby Pancake » 2020-09-16 11:43 (Wednesday)

What's up is that people don't know how Mystical Amplification works.

Any random people can say anything in #support and #main.

Refer to the wiki when in doubt:
https://wiki.originsro.org/wiki/Mystical_Amplification

The first skill cast after using Mystical Amplification uses the Amplification. This includes non-attack skills such as Heal and Energy Coat.
The Amplified magic attack strength applies to ALL active spells, from the beginning of the cast of the Amplified skill.
The effect of Mystical Amplification ends immediately upon the start of the cast of a skill following the Amplified spell's cast. When this happens, all active spells lose their Amplification.
User avatar
Pancake
Player
Player
Drops
Drops
 
Posts: 14
Joined: 2019-02-19 23:56 (Tuesday)
Gender: Not Telling

Re: Mystical Amp + Storm Gust glitch (?)

Postby stockings » 2020-09-16 12:52 (Wednesday)

Aside from the skill desciptions of oRO wiki beeing an exact copy of irowiki classic, this is true. however, it doesn't address what i was trying to convey.

A considerable amount of people seem to think there's an oRO only "bug": You cast Amp -> SG (only once) and over the course of the active AoE it does 10 hits. Supposedly only the first hit is beeing amped, and 9 hits go unamped.

Was this fixed before? Does this happen on special occasions only? Maybe somebody knows something i don't. I wanted some kind of clarification from these "conspiracy theorists", i guess.
User avatar
stockings
Player
Player
Poring
Poring
 
Posts: 2
Joined: 2020-07-31 20:59 (Friday)
Gender: Not Telling


Return to General Chat



Who is online

Users browsing this forum: No registered users and 8 guests